aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml18
1 files changed, 18 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..f28ca29
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,18 @@
+[build-system]
+requires = ["hatchling"]
+build-backend = "hatchling.build"
+
+[project]
+name = "schroedinger"
+version = "0.1"
+requires-python = ">= 3.12"
+dependencies = ["numpy"]
+maintainers = [{name = "Thomas Albers Raviola", email = "thomasgu@uni-bremen.de"},
+ {name = "Tim Suhling", email = "timsuh@uni-bremen.de"}]
+description = ""
+readme = "README.md"
+license = {file = "COPYING"}
+
+[project.scripts]
+schrodinger_solve = "schroedinger.schrodinger_solve:main"
+schrodinger_plot = "schroedinger.schrodinger_plot:main"